Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

How to change the deployment status of PU from "Compromised" to "Intact" ?

Hi All,

I started 1 GSM and 13 GSCs(2 in SpaceZone,11 in ServiceZone) to run my program. I deployed a worker PU with 11 instances (SLA is max-instances-per-vm="1" && sla:zone name="ServiceZone"), and It succeed to run 11 worker PU instances in the cluster. But when restart 8 GSCs in ServiceZone, there are only 10 worker PU instances runing. The deployment status of worker PU is "Compromised". How can I fix this problem?

please refer to the attachment "record.jpg" to know more.

many thanks,

-Michael h4. Attachments

[record.jpg|/upfiles/13759704464558044.jpeg]

[record.jpg|/upfiles/13759704464994344.pjpeg]

{quote}This thread was imported from the previous forum. For your reference, the original is [available here|http://forum.openspaces.org/thread.jspa?threadID=3640]{quote}

asked 2011-04-18 02:51:27 -0500

michael2010 gravatar image

updated 2013-08-08 09:52:00 -0500

jaissefsfex gravatar image
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

Try to deploy the worker PU again. It should provision the missing instance. If this would not work undeploy and deploy. Shay h4. Attachments

[record.jpg|/upfiles/1375970446339264.jpeg]

answered 2011-04-18 02:54:55 -0500

shay hassidim gravatar image
edit flag offensive delete link more

Comments

Hi Shay,

Is there any other way to fix this problem?
I want to know if there is a function to guarantee planned instances equal to running instances, when there are enough GSCs started.

Thanks

-Michael

Attachments

  1. record.jpg
michael2010 gravatar imagemichael2010 ( 2011-04-18 03:16:04 -0500 )edit

You can use the Admin API to validate the deployed PU. See: http://www.gigaspaces.com/wiki/displa... Shay h4. Attachments

[record.jpg|/upfiles/13759704477454901.jpeg]

shay hassidim gravatar imageshay hassidim ( 2011-04-20 16:15:49 -0500 )edit

Hi Shay,

Thank you for reply :-)

But I still didn't find a good way to fix the problem.I just want to know that why I started enough GSCs to run workerPU instances,but some instances can't instantiate successfully.as the Attach File shows "11 GSCs for workerPU, 11 planned workerPU instances,but There are only 10 running workerPU instances.Could you please explain this problem and help me to fix it?

Many thanks

-Michael h4. Attachments

[record.jpg|/upfiles/1375970447674782.jpeg]

michael2010 gravatar imagemichael2010 ( 2011-04-20 22:38:17 -0500 )edit

You will have to look on the gsm and gsc log files. It might be a problem with the CPU utilization. Maybe the machine was utilizing 100% of its CPU. In such a case, the deploy process will not continue. Shay

shay hassidim gravatar imageshay hassidim ( 2011-04-21 02:02:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-04-18 02:51:27 -0500

Seen: 120 times

Last updated: Apr 18 '11