Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

SLA Breach on XP 32 bit

Hi,

I am trying to deploy 6 PU on Windows XP 32 bit Quad Core. My SLA looks like this for each PU: My PU deployment status comes as broken. I keep getting this message in Provision Failure Event: "GSC could not be obtained to provision <<pu name="">>".

In SLA Threshold event I get SLA BREACHED value = -1 min=0 max=0.99 On console for GSC I get this message:

May 12, 2010 11:31:00 AM FINE [com.gigaspaces.grid.gsc]: Threshold=CPU, Status=breached, Value=-1, Low=0, High=1

On Console fo rGSM I get this message:

May 12, 2010 11:35:20 AM INFO [com.gigaspaces.grid.gsm]: A GSC could not be obtained to provision [<<pu>> [1]], count [6]

May 12, 2010 11:35:20 AM INFO [com.gigaspaces.grid.gsm]: Pending allocation request for [<<pu>> [1]] until an available GSC is obtained

May 12, 2010 11:35:34 AM INFO [com.gigaspaces.grid.gsm]: Deploying <<pu name="">>

May 12, 2010 11:35:34 AM INFO [com.gigaspaces.grid.gsm]: A GSC could not be obtained to provision [<<pu>> [1]], count [6]

May 12, 2010 11:35:34 AM INFO [com.gigaspaces.grid.gsm]: Pending allocation request for [<<pu>> until an available GSC is obtained

I have in total 6 PUs. Sometime 2 deploy successfully sometime 4.

http://www.springframework.org/schema... http://www.openspaces.org/schema/sla http://www.openspaces.org/schema/sla/...>

<os-sla:sla cluster-schema="partitioned" number-of-instances="1" max-instances-per-vm="1" max-instances-per-machine="1">
    <os-sla:requirements>
        <os-sla:system name="SoftwareSupport">
            <os-sla:attributes>
                <entry key="Name" value="SOABus-Container-Tag" />
            </os-sla:attributes>
        </os-sla:system>
    </os-sla:requirements>
</os-sla:sla>

</beans>

Can some help explain ? What it OS issue or SLA issue ? What I need to do to make it work ? Same deploy works on Windows Server.

Thanks in advance for all the help.

{quote}This thread was imported from the previous forum. For your reference, the original is [available here|http://forum.openspaces.org/thread.jspa?threadID=3422]{quote}

asked 2010-05-12 12:51:41 -0500

omsoni gravatar image

updated 2013-08-08 09:52:00 -0500

jaissefsfex gravatar image
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

Seems you use the old os-sla:attributes.
Are you using XAP 7 or 6?
How do you start the GSC? Do you provide some override file?
If you use XAP 7, I think you will find the GigaSpaces zones relevant here:
http://www.gigaspaces.com/wiki/display/XAP71/ConfiguringtheProcessingUnitSLA#ConfiguringtheProcessingUnitSLA-DeploymentRequirementsHosts%2CZonesandMachineUtilization
Shay

answered 2010-05-12 13:03:01 -0500

shay hassidim gravatar image
edit flag offensive delete link more

Comments

Thanks for quick reply. We moved from XAP 6 to XAP 7.

Command to start GSC:

"%GSHOME%\bin\gs.bat" start startGSC %APPHOME%\Deployment\datagrid-override.xml

We do use a override file:

<overrides>
    <Component Name="org.jini.rio.qos">
           <Parameter Name="addPlatformCapabilities">
           <![CDATA[
           new org.jini.rio.qos.capability.PlatformCapability {
               new org.jini.rio.qos.capability.software.SoftwareSupport (
                   new Object{"Name", "DataGrid-Container-Tag"})
               }
           ]]>
           </Parameter>
    </Component>
</overrides>

omsoni gravatar imageomsoni ( 2010-05-12 13:14:03 -0500 )edit

Let's see if the zones usage resolve your problem.

To use Zones when deploying your PU you should:
1. Start the GSC using the com.gs.zones system property. Example (for linux):

export EXT_JAVA_OPTIONS=-Dcom.gs.zones=webZone ${EXT_JAVA_OPTIONS}
gs-agent gsa.gsc 2

2. Deploy the PU using the -zones option. Example:

gs deploy -zones webZone myWar.war

Shay

shay hassidim gravatar imageshay hassidim ( 2010-05-12 13:18:40 -0500 )edit

This is what I did for all PU (different zone names), and it did not make any difference:

Starting GSC:

set EXTJAVAOPTIONS=%EXTJAVAOPTIONS% -Dcom.gs.zones=dgszone // and other options
"%GSHOME%\bin\gs.bat" start startGSC %APPHOME%\Deployment\datagrid-override.xml

Deploying:

"%GSHOME%\bin\gs.bat" deploy -zones dgszone -sla %APPHOME%\DataGridService\META-INF\spring\partitioned-sla.xml %APP_HOME%\DataGridService

SLA:

<os-sla:sla cluster-schema="partitioned" max-instances-per-zone="1">
        <os-sla:requirements>
            <os-sla:system name="SoftwareSupport">
                <os-sla:attributes>
                    <entry key="Name" value="DataGrid-Container-Tag" />
                </os-sla:attributes>
            </os-sla:system>
            <os-sla:zone name="dgszone" />
        </os-sla:requirements>
        <os-sla:member-alive-indicator invocation-delay="60000" retry-count="10" retry-timeout="60000" />
</os-sla:sla>

omsoni gravatar imageomsoni ( 2010-05-12 14:12:09 -0500 )edit

I was able to start my GSC in Zones. Is anything wrong with SLA or deploy command ? Why it did not work ?

and read the first line in SLA as <os-sla:sla cluster-schema="partitioned" max-instances-per-zone="dgszone/1">

Edited by: omsoni on May 12, 2010 2:32 PM

omsoni gravatar imageomsoni ( 2010-05-12 14:25:21 -0500 )edit

When using GigaSpaces zones you should not use the datagrid-override.xml when starting the GSC (deprecated). You don't need also to use the sla properties. Just have the cluster-schema and the number of instances together with the relevant zone used with the deploy command. Shay

shay hassidim gravatar imageshay hassidim ( 2010-05-12 17:07:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2010-05-12 12:51:41 -0500

Seen: 59 times

Last updated: May 12 '10