Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

Problem viewing space

Hi,

In the Gigaspaces UI browser, when I locate a secured space, the GUI says I cannot look at the classes or query unless I have the <monitor pu=""> permission or the <space operation=""> permission. How do I set these?

Thanks!

{quote}This thread was imported from the previous forum. For your reference, the original is [available here|http://forum.openspaces.org/thread.jspa?threadID=3377]{quote}

asked 2010-03-02 12:57:20 -0500

dncheu gravatar image

updated 2013-08-08 09:52:00 -0500

jaissefsfex gravatar image
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2010-03-02 13:49:53 -0500

shay hassidim gravatar image
edit flag offensive delete link more

Comments

Hi Shay,

So I've created the space programmaticaly:

UrlSpaceConfigurer spaceConfig = new UrlSpaceConfigurer(spaceName);
spaceConfig.secured(true);
spaceConfig.userDetails(userName, password);
IJSpace space = spaceConfig.space();
GigaSpaceConfigurer gsConfigurer = new GigaSpaceConfigurer(space);
GigaSpace gigaSpace = gsConfigurer.gigaSpace();

That means the principal for accessing the space is defined by userName, password.
In the security management UI, I created a user with those credentials and gave it monitor PU permission. However, I still cannot view the space.

Darien

dncheu gravatar imagedncheu ( 2010-03-02 15:35:04 -0500 )edit

Darien,

Putting aside your code example, when you login using the UI, are you able to see the space? Make sure that you have both of the Monitor PU and at least read space permission. If this is still a problem, please attach your gs-directory.fsm file for us to examine.

Regards, Moran

Meron gravatar imageMeron ( 2010-03-03 05:53:37 -0500 )edit

Yes, I can see the space, and it has the red lock icon. When I click on the query or classes branch on the tree, this is where it says I don't have the PU monitor permission. I have tried created a principal using the same userdetails that were used to create the space and giving it every permission. After login and logout, nothing changes.

One thing I notice is that when I login, the dialog box that shows the history of login has no entries (neither green or red). Does this mean I didn't log in?

Is there a way I can examine the contents of my gs-directory.fsm myself?

Thanks
Darien

dncheu gravatar imagedncheu ( 2010-03-03 08:44:34 -0500 )edit

Darien,

The login dialog box should indicate (in green) that you have successfully logged into the space. The space red lock icon should turn green.
If this is not happening then you are not logged in.

The contents of the gs-directory.fsm file can be examined by the administrator user (which you probably used when adding yourself as a user).
If you are still running into problems, send it over.

Regards,
Moran

Meron gravatar imageMeron ( 2010-03-03 08:56:16 -0500 )edit

Hi,

I had some time lately to get back to this problem.

I have noticed that if my space is running in a multicast enabled mode, I can log in with the dialog showing green entry. As a result, the lock icon turns green.

However, when I run with com.gs.multicast.enabled=false (preferred), when I log in the dialog box shows no entries.

Any idea what's wrong?

Darien

dncheu gravatar imagedncheu ( 2010-03-17 16:58:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2010-03-02 12:57:20 -0500

Seen: 77 times

Last updated: Mar 02 '10