Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

gs-ui query returns no results even though I can see the objects

I added 20,000 objects into the space - each object has many embedded objects and the object graph is large.

I also added 10,000 object into the same space - each of these are flat non-complicated objects.

If I click on the data type in the DataTypes list for the simple object and click on Query, no problem, the query returns all the objects. If I do the same thing for the complicated objects, I get no results.

Where would I go to find out what the problem is?

{quote}This thread was imported from the previous forum. For your reference, the original is [available here|http://forum.openspaces.org/thread.jspa?threadID=4094]{quote}

asked 2013-06-03 11:05:57 -0600

rickfish gravatar image

updated 2013-08-08 09:52:00 -0600

jaissefsfex gravatar image
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

do you have no-arg constructor for all your space objects?

answered 2013-06-03 11:43:04 -0600

shay hassidim gravatar image
edit flag offensive delete link more

Comments

yes, I do

rickfish gravatar imagerickfish ( 2013-06-03 12:29:03 -0600 )edit

Do you have all nested classes serializable? Any error you see from the space side or UI?

shay hassidim gravatar imageshay hassidim ( 2013-06-03 16:50:03 -0600 )edit

As far as I know, all nested classes are Serializable. I had to do this in order for the PU to successfully deploy. I don't see any errors in any of the logs.

If there were a problem with my object tree, wouldn't it be a problem just to write the objects to the space? They are there, they just can't be found in a query.

rickfish gravatar imagerickfish ( 2013-06-04 10:09:03 -0600 )edit

Can you add your application jars/classes to your GS-UI class path? Easiest way to do that would be to place your jars in the <GigaSpacesInstall>/lib/platform/ext folder on the machine where you are launching UI from and restart the UI.

seankumar gravatar imageseankumar ( 2013-06-04 10:32:22 -0600 )edit

Just tried that. I see my jar file in the classpath when GSC is starting. Still the same issue.

rickfish gravatar imagerickfish ( 2013-06-04 13:17:45 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-06-03 11:05:57 -0600

Seen: 100 times

Last updated: Jun 03 '13