Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

Missing xsd schema XAP 10.1

Hey guys,

We have deployed our application a couple of times successfully, however we start seeing this error lately:

2015-05-26 14:55:33,057  SEVERE [com.gigaspaces.admin.cli] - Error deploying [-timeout, 15000, /apps/application.zip]; Caused by: org.openspaces.admin.AdminException: Failed to load application.xml from /apps/application.zip

and...

Caused by: org.springframework.beans.factory.xml.XmlBeanDefinitionStoreException: Line 11 in XML document from resource loaded from byte array is invalid; nested exception is org.xml.sax.SAXParseException; lineNumber: 11; columnNumber: 38; cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'os-admin:application'.

our application.xml looks like:

<beans xmlns="http://www.springframework.org/schema/beans"
   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:context="http://www.springframework.org/schema/context"
   xmlns:os-admin="http://www.openspaces.org/schema/admin"
   xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans-4.1.xsd
                    http://www.springframework.org/schema/context http://www.springframework.org/schema/context/spring-context-4.1.xsd
                    http://www.openspaces.org/schema/admin http://www.openspaces.org/schema/10.1/admin/openspaces-admin.xsd">

    <context:annotation-config />

    <os-admin:application name="app">
        <!-- os-admin:pu declarations -->
    </os-admin:application>
</beans>

Have you seen before?

Thank you!

asked 2015-06-01 13:54:54 -0500

Christian gravatar image
edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
0

Christian

Engineering indicated that this is fixed in 10.1.1

Regards

John

answered 2015-06-04 08:59:06 -0500

jb gravatar image
edit flag offensive delete link more

Comments

Thanks John,

I've compared both schemas though, 10.1.0 vs 10.1.1, and noticed that they are identical. Was the issued somewhere else?

Thank

Christian gravatar imageChristian ( 2015-06-08 08:44:33 -0500 )edit
0

Christian

We're looking into this.

Regards

John

answered 2015-06-01 15:00:58 -0500

jb gravatar image
edit flag offensive delete link more

Comments

Thank you John!

Christian gravatar imageChristian ( 2015-06-01 16:38:27 -0500 )edit
0

Christian

Please upgrade to 10.1.1; it is fixed.

Regards

John

answered 2015-06-04 08:45:39 -0500

jb gravatar image
edit flag offensive delete link more
0

Christian

I'm going to ask Engineering to confirm my suspicions, but for now can you download the version here:

http://www.openspaces.org/schema/10.1...

and replace the file located here with the downloaded file:

gigaspaces-xap-premium-10.1.0-ga/lib/optional/openspaces/schema/org/openspaces/admin/config/

Regards

John

answered 2015-06-01 15:33:01 -0500

jb gravatar image
edit flag offensive delete link more

Comments

Hey John,

Replacing the file didn't solve the problem. Do you have any news?

Christian gravatar imageChristian ( 2015-06-03 12:38:44 -0500 )edit

Christian - I've asked Engineering to have a look. Will update when I've heard back

jb gravatar imagejb ( 2015-06-03 12:44:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-01 13:54:54 -0500

Seen: 259 times

Last updated: Jun 04 '15