Spring Securty 4 with XAP 10

Guys, Does XAP 10.1 work with spring security 4? We are already using spring 4 but spring-security was 3.1.x and when we tried to migrate we got this error:

Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'org.springframework.security.web.access.intercept.FilterSecurityInterceptor#0': Cannot create inner bean '(inner bean)#5437ba05' of type [org.springframework.security.web.access.intercept.DefaultFilterInvocationSecurityMetadataSource] while setting bean property 'securityMetadataSource'; nested exception is org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name '(inner bean)#5437ba05': Unsatisfied dependency expressed through constructor argument with index 0 of type [java.util.LinkedHashMap]: Could not convert constructor argument value of type [java.util.LinkedHashMap] to required type [java.util.LinkedHashMap]: Failed to convert value of type 'java.util.LinkedHashMap' to required type 'java.util.LinkedHashMap'; nested exception is java.lang.IllegalArgumentException: Cannot convert value of type [org.springframework.security.web.util.AntPathRequestMatcher] to required type [org.springframework.security.web.util.matcher.RequestMatcher]: PropertyEditor [org.springframework.security.web.util.matcher.RequestMatcherEditor] returned inappropriate value of type [org.springframework.security.web.util.AntPathRequestMatcher]

asked 2015-08-17 09:23:35 -0500

Christian gravatar image
edit retag flag offensive close merge delete