Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question

Setting Webster Http port

I am trying to configure gigaspaces to use certain range of ports. I changed the services.config to have bindPort = System.getProperty("com.gs.transport_protocol.lrmi.bind-port", "41100-41800");

Looks like space is using the port in the range for transport communication verified using netstat and logs. but having issue with Http port.

Even If I explicitly set the http port using "-Dcom.gigaspaces.start.httpPort=41200" Its randamly picking the port.

Let me know if I am doing some thing wrong here. Attaching the space log for reference.

-Venkat h4. Attachments


{quote}This thread was imported from the previous forum. For your reference, the original is [available here|http://forum.openspaces.org/thread.jspa?threadID=3002]{quote}

asked 2009-04-07 09:37:02 -0500

venkatg gravatar image

updated 2013-08-08 09:52:00 -0500

jaissefsfex gravatar image
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

Are you sure com.gigaspaces.start.httpPort does not allow you to set the Webster port?

Does override file works for you:

    <Component Name="com.gigaspaces.start">
        <Parameter Name="httpPort" Value="9099"/>


answered 2009-05-11 13:22:37 -0500

shay hassidim gravatar image
edit flag offensive delete link more


Most of our spaces are running using gsInstance.
Does gsInstance can start with overrides ???


venkatg gravatar imagevenkatg ( 2009-05-11 13:37:21 -0500 )edit


shay hassidim gravatar imageshay hassidim ( 2009-05-11 13:39:00 -0500 )edit

So we call this a bug ????

venkatg gravatar imagevenkatg ( 2009-05-11 17:03:00 -0500 )edit

GSC support an override file.
gsInstance does not.

shay hassidim gravatar imageshay hassidim ( 2009-05-11 23:44:46 -0500 )edit

If some one interested

There is a different system property when using a gsInstance:


Here is the link for the relevant documentation: http://www.gigaspaces.com/wiki/displa...

Thanks venkat

venkatg gravatar imagevenkatg ( 2009-05-12 08:07:37 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2009-04-07 09:37:02 -0500

Seen: 51 times

Last updated: May 11 '09