Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

gs.xml file not working

Hello,

I have a <my app="">.gs.xml file in my deploy/<my app="">/config/mapping directory which sets the object ID, routing ID and indexing for several of my space objects. However, when the objects are loaded into the space the UI (Service View, Classes Info section) does not reflect these settings. Here is a section from my mapping file:

<gigaspaces-mapping>

<class name="com.model.Service" persist="false" replicate="false" fifo="false">
    <id name="id" auto-generate="false" />  
    <routing name="id"/>  
</class>

<class name="com.model.ServiceUsageGS" persist="false" replicate="false" fifo="false">
    <property name="managedAccountId" index="BASIC"/>
    <id name="id" auto-generate="false" />  
    <routing name="managedAccountId"/>  
</class>

<class name="com.model.SubscriberDenorm" persist="false" replicate="false" fifo="false">
    <property name="telephone" index="BASIC"/> 
    <property name="id" null-value="-1"/>
        <id name="id" auto-generate="false" />
    <routing name="id" />
</class>

</gigaspaces-mapping>

For example, the SubscriberDenorm object should show indexing on the "telephone" property, but, it is listed as "false" in the Indexed column.

Any ideas? Is there a way to debug this? I see no errors in the logs. I'm using XAP 6.6.3.

Thanks,

Bob

{quote}This thread was imported from the previous forum. For your reference, the original is [available here|http://forum.openspaces.org/thread.jspa?threadID=3012]{quote}

asked 2009-04-14 09:15:04 -0600

rrussell gravatar image

updated 2013-08-08 09:52:00 -0600

jaissefsfex gravatar image
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

Bob,
The gs.xml loaded from the same folder where the class files located (preferred location) or from the gigaspaces root/config/mapping folder.

If you want to debug the gs.xml load process have the pojo logging enabled. Check the gs_logging file (located at gigaspaces/config folder) for the exact property to set at the client side.

See more details at the wiki POJO advanced page.

Shay

answered 2009-04-14 13:39:03 -0600

shay hassidim gravatar image
edit flag offensive delete link more
0

Hi Bob,

There is a known bug that may be affecting you. See this thread:

/[/question/4254/space-routing-and-gscs/]&#10630

-Dan

answered 2009-04-19 12:09:26 -0600

subuta gravatar image
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2009-04-14 09:15:04 -0600

Seen: 125 times

Last updated: Apr 19 '09