Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

About Overriding Default Configuration

I have a problem when I try to override default configuration There is what I have done.

1.Open Deployment Wizard choose partitioned schema with 2 instances. 2.Press next> 3.Press ... to add properties 4.Input "/cluster-config/cluster-name"(OR "cluster-config.cluster-name") and "otherthing" 5.Press Deploy I get NullPointerException.

In the output, I see this "CONFIG [ http://com.gigaspaces.core.config ]: Override the cluster config using the xpath expression passed through the custom properties. Old value: new value: <>"

If I load a properties file which contain "/cluster-config/cluster-name=otherthing", it works

Is it a bug?

Edited by: Tsui Chi wing on Mar 11, 2009 4:06 AM

{quote}This thread was imported from the previous forum. For your reference, the original is [available here|http://forum.openspaces.org/thread.jspa?threadID=2941]{quote}

asked 2009-03-11 04:05:27 -0500

cwtsui gravatar image

updated 2013-08-08 09:52:00 -0500

jaissefsfex gravatar image
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

We will check this.

I think it would be simpler if you will have the pu.xml having the following:
<beans

    <bean id="space" class="org.openspaces.core.space.UrlSpaceFactoryBean">
            <property name="url" value="{SPACE_URL}" />
            <property name="schema" value="default" />
            <property name="properties">
                  <props>
                        <prop key="space-config.cluster.enabled">true</prop>
                        <prop key="space-config.cluster.config-url">${CLUSTERFILELOCATION}</prop>
                  </props>
            </property>
    </bean>
</beans>

Where SpaceURL is a property having values such as:java://localhost/mySpace1/mySpace
and CLUSTERFILELOCATION is D://gigaspaces-xap-premium-6.6.2-ga//examples//static_cluster2//config//my-cluster.xml

And deploy via the CLI:
gs.sh pudeploy -properties embed://SPACEURL=java://localhost/mySpace1/mySpace;CLUSTERFILELOCATION=D://gigaspaces-xap-premium-6.6.2-ga//examples//static_cluster2//config//my-cluster.xml pu.jar

Shay

answered 2009-03-13 12:39:40 -0500

shay hassidim gravatar image
edit flag offensive delete link more

Comments

Thank you to provide alternative method.

However, is there anything wrong with my operation?

cwtsui gravatar imagecwtsui ( 2009-03-15 22:21:08 -0500 )edit

cluster-config/cluster-name is not supported property.
Any special reason why you need to use this property?
Shay

shay hassidim gravatar imageshay hassidim ( 2009-03-16 01:00:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2009-03-11 04:05:27 -0500

Seen: 253 times

Last updated: Mar 13 '09