Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

XAP Log Messages

I have been using the latest 6.5 m11 build and have the following log messages.

1.) This log message is displayed by the window I used to start the UI using gs-ui.sh. It comes out every 30 seconds.

May 16, 2008 8:42:11 AM
WARNING java.util.prefs: Couldn't flush user prefs: java.util.prefs.BackingStoreException: java.lang.IllegalArgumentException: Not supported: indent-number

2.) This log message comes out of the window in which I start my space using the gsInstance.sh command. This one seems like no big deal but wanted to check. I am assuming this is because there are other spaces started by other developers which are causing this particular error message? My space or some component of the space is attempting to contact some other space using the localhost address??

May 15, 2008 4:43:35 PM
INFO net.jini.discovery.LookupDiscovery: exception occurred during unicast discovery to 127.0.0.1:47266 with constraints InvocationConstraintsreqs: {}, prefs: {}
Caused by: java.net.ConnectException: Connection refused

3.) In the GUI for my space the cloud symbol is outlined in red and has an exclamation in it. I assume this is trying to inform me of some sort of error condition but I do not see anything in the menus or right-click help to show me the error condition. Any help on this so that I can see what is the issue?

TIA

Mike

This thread was imported from the previous forum.
For your reference, the original is available here

asked 2008-05-16 09:59:24 -0500

mcnoche gravatar image

updated 2013-08-08 09:52:00 -0500

jaissefsfex gravatar image
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

The "exception occurred during unicast discovery" is displayed starting with 6.5 once your client trying to access a Jini lookup that does not exists on this host or not listening on this port.

Jini lookup listening by default with 6.0 release on 4160 port and with 6.5 on port 4162.

The cloud with the exclamation icon means the UI can't connect to the Jini lookup. This might happen when the JVM running the Lookup is very busy (doing GC).

You you running the GSM/LUS in a separate JVM or using the gs-all script?

Shay

answered 2008-05-19 08:47:34 -0500

shay hassidim gravatar image
edit flag offensive delete link more

Comments

I've a similar problem. How can I fix it to avoid the exception?

Or it's okay not to fix it?

Joe

mytofu gravatar imagemytofu ( 2008-12-22 01:24:51 -0500 )edit

Do you have a warning or an exception thrown?
What's the error you are getting?
Do you have the LOOKUPLOCATORS variable set somewhere in your environment?

Shay

shay hassidim gravatar imageshay hassidim ( 2008-12-22 06:55:00 -0500 )edit

It just keeps printing the warning message:

...Couldn't flush user prefs: java.util.prefs.BackingStoreException: java.lang.IllegalArgumentException: Not supported: indent-number

I didn't set the LOOKUPLOCATORS explicitly. Should it be set inside bin/setenv.sh?

Joe

mytofu gravatar imagemytofu ( 2008-12-22 08:58:05 -0500 )edit

This might come from the UI. I was thinking your problem was related to the lookup message.

Any chance the UI trying to write its preferences file to a protected folder?

Have you installed GigaSpaces using root user and trying to run it using different user? (I mean the UI).

Shay

shay hassidim gravatar imageshay hassidim ( 2008-12-22 09:13:14 -0500 )edit

I just unzip the gigaspaces package using normal user account. Is the preferences are stored in the home directory or inside the gigaspaces folder? Do I need to change the read/write mode of any of them?

Thank you very much,

Joe

mytofu gravatar imagemytofu ( 2008-12-22 09:40:34 -0500 )edit
0

Typically, when we are in development mode we are running separate spaces for each developer using the gsInstance.sh script. There are so many options and ways to run the GS env we just tried to pick one which was simple and can be run from the command line. I assume that the gsInstance.sh starts the LUS? Is there another way you would suggest running the GS env?

Mike

answered 2008-05-19 09:07:52 -0500

mcnoche gravatar image
edit flag offensive delete link more

Comments

The gsInstance running a LUS by default.

You might have different LOOKUPGROUPS for each developer when running gsInstance or deploying your spaces into the GSC. Change the LOOKUPGROUPS environment variable to have the same value as %USERNAME%. This how each developer will not interfere with other developers running LUS.

Shay

shay hassidim gravatar imageshay hassidim ( 2008-05-19 09:20:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2008-05-16 09:59:24 -0500

Seen: 38 times

Last updated: May 19 '08