Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

No gs> prompt

I just downloaded and installed gigaspace. From the output in my cmd window (see excerpt below) it seems to start ok but after startup I don't get a gs> prompt and the command window seems to be dead to any input except ctrl-c which evokes the "terminate batch job?" question. Is something wrong with my installation?

I am new to gigaspaces so I may be missing something obvious. Many thanks for your help.

12-Oct-2008 09:37:06 INFO [com.gigaspaces.cache]: Cache manager created with policy [ALL IN CACHE], p ersistency mode [memory]

12-Oct-2008 09:37:06 INFO [com.gigaspaces.core.common]: Space <myspace_container:myspace> with url [/ ./mySpace?schema=default&properties=gs&groups=gigaspaces-6.6.0-XAP-ga&state=star ted] started successfully

{quote}This thread was imported from the previous forum. For your reference, the original is [available here|http://forum.openspaces.org/thread.jspa?threadID=2652]{quote}

asked 2008-10-12 03:38:43 -0600

subuta gravatar image

updated 2013-08-08 09:52:00 -0600

jaissefsfex gravatar image
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

Seems the CLI application hangs when trying to discover the lookup service.
Lets try explicitly to define the location of the lookup service rather having it discovered using multicast.

set the following before calling the gs.bat command or modify the setenv.bat to have the following:
set LOOKUPLOCATORS=yourIPmachine

It this won't solve the problem modify the:
\gigaspaces-xap-6.6.0-ga\config\gs_logging.properties
to have:
com.gigaspaces.admin.cli.level = ALL
com.gigaspaces.lrmi.level = ALL

and run gs,bat again.
This will generate a file here:
\gigaspaces-xap-6.6.0-ga\logs\gigaspacescli0_0.log

Please post this file.

Shay

answered 2008-10-12 08:46:05 -0600

shay hassidim gravatar image
edit flag offensive delete link more

Comments

Hi Shay and Guy

Sorry I didn't see your responses until now. The issue was a severe case of pilot error :) and is resolved.

-Dan

subuta gravatar image subuta  ( 2008-12-17 06:14:22 -0600 )edit
0

Hi,

I advise you to follow http://www.gigaspaces.com/wiki/display/XAP66/QuickStartGuide
It's a very nice (and short) quick start guide.

Cheers,
Guy

answered 2008-10-12 04:21:49 -0600

nirpaz gravatar image
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2008-10-12 03:38:43 -0600

Seen: 302 times

Last updated: Oct 12 '08