Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

Deploying PU jar throws error

I am trying to deploy the attached “data grid” it contains “pu.xml and sla.xml” but when I remove the sla.xml its working fine.

CLI Command:

gs deploy "D:\tools\gigaspaces-xap-premium-9.1.2-ga\deploy\templates\datagrid"

but when I add the sla.xml file its not deploying. whats wrong in sla.xml file? h4. Attachments

[imdg.zip|/upfiles/1375970210769663.txt]

[2013-03-12~08.01-gigaspaces-cli-192.168.1.102-8044.log|/upfiles/13759702102033365.txt]

[2013-03-12~07.24-gigaspaces-gsm_3-get4gopim-PC-6416.log|/upfiles/13759702109235865.txt]

[spring.zip|/upfiles/13759702108411267.zip]

{quote}This thread was imported from the previous forum. For your reference, the original is [available here|http://forum.openspaces.org/thread.jspa?threadID=4048]{quote}

asked 2013-03-12 22:10:47 -0600

get4gopim gravatar image

updated 2013-08-08 09:52:00 -0600

jaissefsfex gravatar image
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

See attached modified jar.
See below how you should have it structured:
http://wiki.gigaspaces.com/wiki/display/XAP91/TheProcessingUnitStructureandConfiguration

It should be:

cluster-schema="async_replicated"

and not

cluster-schema="async-replicated"

To deploy:

gs deploy imdg.zip

This will deploy an async replicated space cluster named dataGrid.

Shay

Attachments

  1. imdg.zip

answered 2013-03-12 22:56:32 -0600

shay hassidim gravatar image
edit flag offensive delete link more

Comments

Thanks Shay,

After changing the config its working fine.

get4gopim gravatar imageget4gopim ( 2013-03-15 02:22:09 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-03-12 22:10:47 -0600

Seen: 14 times

Last updated: Mar 12 '13