Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

Lookup issue

Hi guys,

I'm having some problem here with my network environment and the gigaspace locators, I'll try to explain.

My server machine real ip is: - addr:192.168.213.115 Bcast:192.168.213.127 Mask:255.255.255.192

From my client machine I can access the server above with the ip: - 146.62.213.115

and my client machine ip address is: - addr: 164.137.81.83 Mask:255.255.254.0 gateway:164.137.80.1

When I try to access the space with the JINI URL => jini:////myClientGrid?locators=146.62.213.115:4162 the following exepction is thrown

Caused by: org.openspaces.core.space.CannotFindSpaceException: Failed to find sp ace with url [jini:////myClientGrid?locators=146.62.213.115:4162&groups=gigaspaces-6.5.1-XAP-ga&state=started]; nested exception is com.j_spaces.core.client. FinderException: LookupFinder failed to find service using the following service attributes:

     Service attributes: [com.j_spaces.lookup.entry.State(state=started,electable=null,replicable=null)]
     Service attributes: [net.jini.lookup.entry.Name(name=souzaCruzGrid)]
     Lookup timeout: [5000]
     Classes: [interface com.j_spaces.core.service.Service]
     Jini Lookup Groups: [gigaspaces-6.5.1-XAP-ga]
     Jini Lookup Locators: 146.62.213.115:4162
     Number of Lookup Services: 0

    at org.openspaces.core.space.UrlSpaceFactoryBean.doCreateSpace(UrlSpaceFactoryBean.java:289)
    at org.openspaces.core.space.AbstractSpaceFactoryBean.afterPropertiesSet(AbstractSpaceFactoryBean.java:136)
    at org.springframework.beans.factory.support.AbstractAutowireCapableBean Factory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:1368)
    at org.springframework.beans.factory.support.AbstractAutowireCapableBean Factory.initializeBean(AbstractAutowireCapableBeanFactory.java:1334)
    ... 16 more

Caused by: com.j_spaces.core.client.FinderException: LookupFinder failed to find service using the following service attributes:

     Service attributes: [com.j_spaces.lookup.entry.State(state=started,electable=null,replicable=null)]
     Service attributes: [net.jini.lookup.entry.Name(name=souzaCruzGrid)]
     Lookup timeout: [5000]
     Classes: [interface com.j_spaces.core.service.Service]
     Jini Lookup Groups: [gigaspaces-6.5.1-XAP-ga]
     Jini Lookup Locators: 146.62.213.115:4162
     Number of Lookup Services: 0

    at com.j_spaces.core.client.LookupFinder.find(SourceFile:332)
    at com.j_spaces.core.client.SpaceFinder.a(SourceFile:1031)
    at com.j_spaces.core.client.SpaceFinder._find(SourceFile:615)
    at com.j_spaces.core.client.SpaceFinder.internalFind(SourceFile:412)
    at com.j_spaces.core.client.SpaceFinder.internalFind(SourceFile:387)
    at com.j_spaces.core.client.SpaceFinder.find(SourceFile:206)
    at org.openspaces.core.space.UrlSpaceFactoryBean.doCreateSpace(UrlSpaceFactoryBean.java:286)

h4. Attachments

[setenv-ny.txt|/upfiles/13759715319519073.txt]

[startgrid-ny.txt|/upfiles/13759715315014273.txt]

{quote}This thread was imported from the previous forum. For your reference, the original is [available here|http://forum.openspaces.org/thread.jspa?threadID=2589]{quote}

asked 2008-09-11 09:06:19 -0500

htota gravatar image

updated 2013-08-08 09:52:00 -0500

jaissefsfex gravatar image
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

I Is this windows or linux? How your hosts file looks? Are u sure the machins can ping each other?
- Do u have anti virus installed? Can u disable it on all machins and test?
- Are u sure client and space machins using the same GigaSpaces release?
- Are u sure u start the space using
"/./myClientGrid" URL ?
- Is there anything listening on port 4162?

Shay
Sent from my BlackBerry® smartphone with SprintSpeed

Attachments

  1. setenv-ny.txt
  2. startgrid-ny.txt

answered 2008-09-11 09:26:49 -0500

shay hassidim gravatar image
edit flag offensive delete link more

Comments

- The space is installed on a Linux server and the client is a windows machine.
- The hosts looks like :


127.0.0.1 z1t1brpapta26.br.batgen.com z1t1brpapta26 localhost.localdomain localhost
192.168.212.150 brpald74 brpald74.br.batgen.com
192.168.208.164 z1t1brpaplh04 z1t1brpaplh04.br.batgen.com
192.168.213.100 brpala34 brpala34.br.batgen.com
192.168.209.92 z1t1brpaplm12 z1t1brpaplm12.br.bagen.com


- I tried to disable the antivirus because I've seem in some topic in the forum, it does not work
- Yes the server ping my client machine and from my client I can ping the server with a virtual ip : 146.62.213.115
- Yes all machies are running gigaspaces-xap-6.5.1-ga
- I start gigaspace with the following url:

./gs.sh pudeploy -cluster schema=partitioned-sync2backup total_members=2,1 -properties embed://dataGridName=myClientGrid -override-name myClientGrid /templates/datagrid

- No only gigaspaces using the 4162 port

Attachments

  1. setenv-ny.txt
  2. startgrid-ny.txt
htota gravatar imagehtota ( 2008-09-11 09:56:15 -0500 )edit

Hi, It looks like a typical bug caused by Linux installation - it puts hostname to the localhost 127.0.0.1 - see /etc/hosts - z1t1brpapta26.br.batgen.com and z1t1brpapta26. If gigaspaces has been started on these hostnames it will not be accessible from outside.

Hostname should be set to IP address assigned to the public interface of the box (for the public interface IP address see /sbin/ifconfig -a)

Peter Weinstein

Edited by: Peter Weinstein on Sep 11, 2008 12:50 PM h4. Attachments

[setenv-ny.txt|/upfiles/1375971532673334.txt]

[startgrid-ny.txt|/upfiles/1375971532847674.txt]

peterweinstein gravatar imagepeterweinstein ( 2008-09-11 12:50:22 -0500 )edit

Thanks for reply,

I'll try to do that but in my setenv.sh I added the following lines:

LOOKUPLOCATORS=192.168.213.115 NIC_ADDR=192.168.213.115

the real ip address overiding the default configuration h4. Attachments

[setenv-ny.txt|/upfiles/13759715326227461.txt]

[startgrid-ny.txt|/upfiles/13759715323832761.txt]

htota gravatar imagehtota ( 2008-09-11 14:15:56 -0500 )edit

Like I said the configurations I made overring the SO configurations. The servers are in a datacenter, you guys know if the JINI protocol has some restrinctions to access machines with virtual IP? I made a test with a windows machine in the same network the servers are and it worked fine. h4. Attachments

[setenv-ny.txt|/upfiles/13759715329758982.txt]

[startgrid-ny.txt|/upfiles/13759715326404782.txt]

htota gravatar imagehtota ( 2008-09-12 09:56:00 -0500 )edit

looks like there is a multicast issue with network/switch try enabling and using unicast discovery. check following for details

http://www.gigaspaces.com/wiki/displa...

Thanks h4. Attachments

[setenv-ny.txt|/upfiles/13759715333097307.txt]

[startgrid-ny.txt|/upfiles/13759715337007107.txt]

venkatg gravatar imagevenkatg ( 2008-09-12 11:30:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2008-09-11 09:06:19 -0500

Seen: 109 times

Last updated: Sep 11 '08