Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
1

groovy version incompatible with GS10.2

Hi Team,

I have been using GS 9.7.2 and my application is written completely in groovy we use groovy 2.3.6. It all worked fine till we decided to upgrade to GS10.2. Now when i deploy my application, i keep getting errors like

Caused by: groovy.lang.GroovyRuntimeException: Conflicting module versions. Module [groovy-all is loaded in version 2.2.1 and you are trying to load version 2.3.6 at org.codehaus.groovy.runtime.metaclass.MetaClassRegistryImpl$DefaultModuleListener.onModule(MetaClassRegistryImpl.java:509) at org.codehaus.groovy.runtime.m12n.ExtensionModuleScanner.scanExtensionModuleFromProperties(ExtensionModuleScanner.java:77) at org.codehaus.groovy.runtime.m12n.ExtensionModuleScanner.scanExtensionModuleFromMetaInf(ExtensionModuleScanner.java:71) at org.codehaus.groovy.runtime.m12n.ExtensionModuleScanner.scanClasspathModules(ExtensionModuleScanner.java:53) at org.codehaus.groovy.runtime.metaclass.MetaClassRegistryImpl.<init>(MetaClassRegistryImpl.java:110) at org.codehaus.groovy.runtime.metaclass.MetaClassRegistryImpl.<init>(MetaClassRegistryImpl.java:71) at groovy.lang.GroovySystem.<clinit>(GroovySystem.java:33) ... 44 more

Does GS10.2 comes bundled with groovy 2.2.1 and do i need to downgrade my groovy version to be able to deploy on GS grid ?

Thanks.

asked 2016-04-07 11:41:11 -0500

Harvey gravatar image
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

Harvey

It was upgraded to 2.2.1in v10:

http://docs.gigaspaces.com/release_no...

Please also see this page to determine if there are any known issues:

http://docs.gigaspaces.com/release_no...

You should be able to simply replace the jars, or to downgrade.

Regards

John

answered 2016-04-10 17:24:21 -0500

jb gravatar image
edit flag offensive delete link more

Comments

1

The key point here is that if i am able to deploy my application build on groovy 2.3.6 on GS 9.7.2 which used groovy 1.8.6. I should have been deploy my application on GS10.2 which uses groovy 2.2.1. ??

Harvey gravatar imageHarvey ( 2016-04-10 20:57:54 -0500 )edit

Harvey

Please open a support case for an upgrade of groovy.

Regards

John

jb gravatar imagejb ( 2016-04-11 11:42:40 -0500 )edit

we have the same problem.

dgt79 gravatar imagedgt79 ( 2016-04-13 05:20:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-07 11:41:11 -0500

Seen: 1,506 times

Last updated: Apr 10 '16