Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

Space memory management in XAP.NET

I wondering how to set up memory management for the space using XAP.NET (there are a lot of articles about Java). I found the setting in docs, but its working only for Java, not .Net version of gigaspaces: space-config.engine.memory_usage.high_watermark_percentage

So, how can I configure high_watermark_percentage for GSC for .NET version of gigaspaces?

asked 2016-10-27 12:00:03 -0500

Ivan Y gravatar image
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

Ivan

For JVM settings, follow the instructions here:

http://docs.gigaspaces.com/xap102net/...

For Space properties such as watermarks and thresholds, see this page:

http://docs.gigaspaces.com/xap102net/...

Regards

John

answered 2016-10-27 12:09:59 -0500

jb gravatar image
edit flag offensive delete link more

Comments

thank you for answer! To clarify some details I'd like to show an examples. To set up memory with your Processing Unit config file - pu.config - you can just add a few line:

<ProcessingUnit>
    <EmbeddedSpaces>
      <add Name="mjGame">
        <Properties>
          <add Name="space-config.engine.cache_policy" Value="0"/>
          <add Name="space-config.engine.cache_size" Value="100000"/>
          <add Name="space-config.engine.memory_usage.high_watermark_percentage" Value="60" />
          <add Name="space-config.filters.Statistics.enabled" Value="false" />
          <add Name="space-config.engine.memory_usage.write_only_block_percentage" Value="58"/>
          <add Name="space-config.engine.memory_usage.write_only_check_percentage" Value="55"/>
          <add Name="space-config.engine.memory_usage.low_watermark_percentage" Value="40" />
        </Properties>
      </add>
    </EmbeddedSpaces>
  </ProcessingUnit>

if you wanna set up global setting for all the GSC instances - you should use a default setting file located here: C:\GigaSpaces\XAP.NET-10.2.1-x64\NET v4.0\Config\Default.config and use SystemProperties section for the settings:

    <SystemProperties>
        <add Name="com.gs.engine.cache_policy" Value="0"/>
        <add Name="com.gs.memory_usage_enabled" Value="true"/>
        <add Name="com.gs.filters.statistics.enabled" Value="false"/>

    </SystemProperties>
Ivan Y gravatar imageIvan Y ( 2016-11-15 14:54:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-10-27 12:00:03 -0500

Seen: 1,943 times

Last updated: Oct 27 '16