Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

Redo logs are overflowing to disk even though they are configured to "drop-oldest"

Hi,

I am testing various redo log configurations with a Mirror that sends data to a database with Gigaspaces 10.1. I noticed that even if I choose 100% of the redo logs should be saved in memory with “drop-oldest” configuration specified, I always see the redo logs overflowing to disk when I disable the network connection to the database. I am not sure why this is the case as I would expect the redo logs to be kept in the spaces?

Example Space configuration: 2048m,20480m,1 i.e. 20GB maximum memory capacity divided into 10 spaces, each space being 2GB. 1 Mirror Service space = 2GB cluster-config.mirror-service.redo-log-capacity = 100000 cluster-config.groups.group.repl-policy.redo-log-memory-capacity = 100

I have tried to decrease the number of packets saved in the redo logs to 20000 and and am seeing the same issue.

Thanks, KP

asked 2017-09-27 12:42:14 -0600

kp gravatar image
edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

Hi, Relevant parameters are:cluster-config.groups.group.repl-policy.redo-log-memory-capacity and cluster-config.groups.group.repl-policy.redo-log-capacity that should be the same.cluster-config.mirror-service.redo-log-capacity should be equal or less to the above numbers.

answered 2017-09-28 04:06:09 -0600

Ester gravatar image
edit flag offensive delete link more

Comments

Thanks Ester, am retesting with suggested configuration.

kp gravatar imagekp ( 2017-10-04 05:45:26 -0600 )edit

Hi Ester, I have configured the three suggested variables to 30000 but am still seeing redo logs overflowing to disk after disconnecting the DB from the network. Do you have any further advice on how to debug what is going wrong? Thanks, KP

kp gravatar imagekp ( 2017-10-04 11:02:05 -0600 )edit

Hi, We would like t further investigate this case, can you please open a support case via our support portal: https://support.gigaspaces.com/VF_Com... And we will take it from there?

Thanks, Inbar

inbarc gravatar imageinbarc ( 2017-10-08 03:18:55 -0600 )edit

Case 00011458 has been created.

kp gravatar imagekp ( 2017-10-11 04:43:25 -0600 )edit

Hi,

Just want to double check if cluster-config.mirror-service.redo-log-capacity specifies the number of replication packets saved when the connection to a DB is removed for examlpe? Whereas cluster-config.groups.group.repl-policy.redo-log-capacity specifies the number of replication packets to save when a target space is no longer available? Am trying to fully understand the difference. Thanks, KP

kp gravatar imagekp ( 2017-10-17 08:09:22 -0600 )edit
0

Hi, In order to avoid overflowing to disk you should configure both redo-log-capacity and redo-log-memory-capacity to same value.

Regards, Ester.

answered 2017-09-28 02:47:59 -0600

Ester gravatar image
edit flag offensive delete link more

Comments

Hi Ester,

Thank you very much for your reply. I double checked my figures, the redo-log-capacity and redo-log-memory-capacity actually do have the same value. My initial reporting of 100 for redo-log-memory-capacity came from the figure of "100%" of redo log size saved in memory which equates to the same figure as redo-log-capacity. So I am still unsure why the redo logs overflow to disk.

Regards, KP

kp gravatar imagekp ( 2017-09-28 03:25:39 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-09-27 12:40:52 -0600

Seen: 115 times

Last updated: Sep 28