Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

HandShake Failed on connecting to gigaspace server

Guys,

I am testing the upgrade from 9.6.4 version of gigaspace to 12.2.1 version. Our processes on 9.6.4 version is working perfectly fine through 9.6.4 client.

Gigaspace server upgraded to version 12.2.1 and spaces deployed successfully. However when we try to execute the same process on gigaspace server (12.2.1) using 9.6.4 on client its giving handshake failed error while making the jini connection.

Server logs start printing this

[lus][2/5151] 2018-01-23 06:57:17,521 LUS WARNING [com.gigaspaces.lrmi] - Closing connection to /172.17.0.3:42202 because of java.net.ConnectException: Handshake failed, expecting message of up to 5120 bytes, actual size is: 49036 bytes, offending address is /172.17.0.3:42202; Caused by: java.net.ConnectException: Handshake failed, expecting message of up to 5120 bytes, actual size is: 49036 bytes, offending address is /172.17.0.3:42202 [lus][2/5151]
2018-01-23 06:57:17,521 LUS FINE [com.gigaspaces.lrmi] - Connection with client closed from [/172.17.0.3:42202] endpoint.

Please let us know if there is any possibility in which we can connect 9.6.4 client to 12.2.1 server.

asked 2018-01-23 09:39:35 -0500

Yasir gravatar image
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

Hi, Our backwards policy usually supports connecting from older client which is 2 major versions behind the server, In this case its more and we did not test it.Having said the above, the exception you got indicate we got handshake message that is larger from what we expected for handshake and we added this protection against getting messages that are not in our lrmi protocol and might be results of port scanning applications but not sure why you got it if the other side was just older client. Anyhow, I suggest upgrade the clients as well, if you can't please contact our support and we will continue from there.

Regards, Ester.

answered 2018-01-29 05:46:33 -0500

Ester gravatar image
edit flag offensive delete link more

Comments

Hi,

You can try disabling this protocol validation by using: com.gs.transport_protocol.lrmi.protocol-validation-disabled=true

Regards,

Yuval

Yuval gravatar imageYuval ( 2018-01-29 06:58:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-01-23 09:39:35 -0500

Seen: 107 times

Last updated: Jan 29