Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

Failed to find active GSM to deploy

I'm getting an strange behavior when I deploy a PU. In the console dump for the command that I run: su - gigaspaces -c "/opt/gigaspaces/bin/gs.sh deploy -properties embed://web.port=8800 -cluster total_members=1 -max-instances-per-vm 1 -max-instances-per-machine 1 /home/gigaspaces/deploy/application.war"

I get: Found 3 GSMs Deploying [application.war] with name [application] under groups [gscluster121] and locators [jini://node01:4174/, jini://node03:4174/, jini://node04:4174/]

And then: Error deploying [-properties, embed://web.port=8800, -cluster, total_members=1, -max-instances-per-vm, 1, -max-instances-per-machine, 1, /home/gigaspaces/deploy/application.war]:org.jini.rio.core.OperationalStringException: Failed to deploy [application]

On the cli log file that was created for the deploy I'm seeing the following:

2019-05-30 15:32:28,737 SEVERE [com.gigaspaces.admin.cli] - Error deploying [-properties, embed://web.port=8800, -cluster, total_members=1, -max-instances-per-vm, 1, -max-instances-per-machine, 1, /home/gigaspaces/deploy/application.war]; Caused by: org.jini.rio.core.OperationalStringException: Failed to deploy [application] at org.jini.rio.monitor.ProvisionMonitorImpl.deploy(ProvisionMonitorImpl.java:546) at org.jini.rio.monitor.ProvisionMonitorAdminImpl.deploy(ProvisionMonitorAdminImpl.java:121) at org.jini.rio.monitor.DeployAdminGigaspacesMethodinternalInvoke3.internalInvoke(Unknown Source) at com.gigaspaces.internal.reflection.fast.AbstractMethod.invoke(AbstractMethod.java:45) at com.gigaspaces.lrmi.LRMIRuntime.invoked(LRMIRuntime.java:441) at com.gigaspaces.lrmi.nio.Pivot.consumeAndHandleRequest(Pivot.java:494) at com.gigaspaces.lrmi.nio.Pivot.handleRequest(Pivot.java:572) at com.gigaspaces.lrmi.nio.Pivot$ChannelEntryTask.run(Pivot.java:173) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) at java.lang.Thread.run(Thread.java:748) Caused by: org.jini.rio.core.OperationalStringException: Failed to find active GSM to deploy [application]

So, mixed feelings here. At the beginning 3 GSM was found, then it failed to find an active one.

I don't see any errors on the GSM/GSC errors. Any ideas? Thanks

asked 2019-05-30 13:45:36 -0500

LukeAva gravatar image

updated 2019-05-30 17:27:51 -0500

edit retag flag offensive close merge delete

Comments

Hi,

What version of XAP are you using?

Dixson Huie gravatar imageDixson Huie ( 2019-05-31 14:39:51 -0500 )edit

Hi Dixson. I'm running 12.1.1 over Linux (RHEL6.10) with Oracle JDK 1.8

LukeAva gravatar imageLukeAva ( 2019-06-03 08:13:53 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

If using XAP manager, don't start lus or gsm processes. XAP manager process contains lus and gsm functionality within it.

answered 2019-06-04 08:53:38 -0500

Dixson Huie gravatar image
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-05-30 13:45:36 -0500

Seen: 272 times

Last updated: Jun 04