Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

How do I force the Serilization Type of 1 ( Light on a client code )

I postd this question on OpenSpaces.org , may be that was not right.

I have a cluster , with 4 spaces running in a replicated partition of 2 each. The DefaultConfig_DCache.xml has the Serialization Type set to 1. I can go into the Space Browser and confirm that both the space and the DCache ( from gs.sh ) have the Serialization type as 1.

Yet on the client side, I can not force the cluster proxy to work with Serialization Type of 1, even though my understanding is that the cluster controls the Serialization type.

What am I missing here? I am working with 6.0.3XAP GS.

{quote}This thread was imported from the previous forum. For your reference, the original is [available here|http://forum.openspaces.org/thread.jspa?threadID=2403]{quote}

asked 2008-06-24 00:08:00 -0500

updated 2013-08-08 09:52:00 -0500

jaissefsfex gravatar image
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

Can you explain what do you mean by: "on the client side, I can not force the cluster proxy to work with Serialization Type of 1"

The space serialization mode determined using the space-config.serialization-type (that is space config and not cluster config) XPATH property. The local cache (space) serialization mode determined using the DefaultConfig_DCache.xml <serialization-type> tag.

Shay

answered 2008-06-24 07:23:51 -0500

shay hassidim gravatar image
edit flag offensive delete link more

Comments

That is what I thought. I have a DefaultConfig_DCache.xml at the client JVM witht the right Serilization Type. That generally used to be enough, but it seems that is no longer being picked up and the client JVM fails when trying to write in.

_<serialization-type>1</serialization-type>_ is what has been always working. But i fail to grasp, as to why in 6.0.3 it suddenly an issue.

vishalsant gravatar imagevishalsant ( 2008-06-24 08:12:52 -0500 )edit

With which version this worked?
Are you sure the DefaultConfig_DCache.xml located at application CLASSPATH\config ?
Shay

shay hassidim gravatar imageshay hassidim ( 2008-06-24 11:39:52 -0500 )edit

The build is 6.0.3. I am sure the DefaultConfig_DCache.xml is located at application CLASSPATH\config. <serialization-type>1</serialization-type> is from the DefaultConfig_DCache.xml that lies in config that lies in the classpath of a tomcat servlet engine. This now is effecting our prod systems. Is there hard coding that can be done to set the SerilizationTypr? I have seen it work on 5.0.2.

vishalsant gravatar imagevishalsant ( 2008-07-02 09:45:21 -0500 )edit

Hi, We will need to see some more logs of: 1. Please turn on logging to see which DefaultConfig_DCache.xml file is loaded and from which location? Set com.gigaspaces.common.resourceloader.level = FINE and com.gigaspaces.common.spaceurl.level = ALL in gs_logging.properties, or system prop in the server and client command line: -Dcom.gigaspaces.common.resourceloader.level=FINE and -Dcom.gigaspaces.common.spaceurl.level=ALL

  1. Execute the bin/PlatformInfo.bat and send the output.

  2. If you use gs.properties and XPath like overrides, please set the following XPath within it: space-config.serialization-type = 1 XPath overrides everything, even if you have hard coded value in any of the files.

HTH Gershon

gershond gravatar imagegershond ( 2008-07-02 12:34:44 -0500 )edit

Hi,
What you have described makes sense indeed but I am afraid I've missed the current issue which blocks you. If the serialization mode override works for you, do you have any other issue besides that?

Gershon

gershond gravatar imagegershond ( 2008-07-24 00:11:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2008-06-24 00:08:00 -0500

Seen: 39 times

Last updated: Jun 24 '08