Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

Linux GSC can't register to a Windows GSM

Hello,

I've been trying GigaSpaces (6.0) for a few weeks and everything was fine until I try to launch a GSM on a WinXP machine and a GSC on an Ubuntu one. The GSC detects the GSM but can't register. It gives this output :


INFO [org.jini.rio.cybernode]: ProvisionManager discovered com.gigaspaces.grid.gsm.GSMProxy@c5caf62f

25 juin 2008 10:40:42 ATTENTION [org.jini.rio.cybernode]: Recovering ProvisionManager Lease attempt retry count [0] Caused by: net.jini.core.lease.LeaseDeniedException: Getting ServiceRecords 25 juin 2008 10:40:45 CONFIG [com.gigaspaces.grid.gsc]: Loading [0] initialServices

25 juin 2008 10:40:45 ATTENTION [org.jini.rio.cybernode]: Recovering ProvisionManager Lease attempt retry count [1] Caused by: net.jini.core.lease.LeaseDeniedException: Getting ServiceRecords 25 juin 2008 10:40:48 ATTENTION [org.jini.rio.cybernode]: Recovering ProvisionManager Lease attempt retry count [2] Caused by: net.jini.core.lease.LeaseDeniedException: Getting ServiceRecords 25 juin 2008 10:40:51 ATTENTION [org.jini.rio.cybernode]: Recovering ProvisionManager Lease attempt retry count [3] Caused by: net.jini.core.lease.LeaseDeniedException: Getting ServiceRecords 25 juin 2008 10:40:52

ATTENTION [org.jini.rio.cybernode]: Unable to register to ProvisionManager com.gigaspaces.grid.gsm.GSMProxy@c5caf62f

And for the GSM :

ATTENTION [org.jini.rio.monitor.feedback]: Registering a ServiceBeanInstantiator

Caused by: java.rmi.ConnectException: Connect Failed; nested exception is :

java.net.ConnectException: Connection refused: connect

If I do the contrary (GSM on linux and GSC on Windows), nothing seems to happen. I don't understand the cause of this behavior and I haven't seen anyone else with the same problem. Have I missed anything obvious ?

Guillaume.

{quote}This thread was imported from the previous forum. For your reference, the original is [available here|http://forum.openspaces.org/thread.jspa?threadID=2409]{quote}

asked 2008-06-25 04:17:00 -0600

gtinon gravatar image

updated 2013-08-08 09:52:00 -0600

jaissefsfex gravatar image
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

Seems as windows and linux machines does not have their multicast settings configured properly. Take a look on our installation and multicast config pages. It includes steps describing how to enable multicast on linux (which might be the problem) and windows.

Another solution would be to use unicast lookup service discovery: to explicitly define the machine running the GSM. This is done via the LOOKUPLOCATORS=MACHINERUNNINGGSM in the Gigaspaces root/bin/setenv of each machine running GSC or GSM.
Later , when having a client accessing a space, the space url should include the locators argument:
Jini:////spaceName?locators=MACHINERUNNINGGSM

This will allow the client to find the lookup service (acts as the directory service of the system)..

Shay
Sent from my BlackBerry® smartphone with SprintSpeed

answered 2008-06-25 06:53:19 -0600

shay hassidim gravatar image
edit flag offensive delete link more

Comments

Thanks for your early answer. I've checked your multicast config pages and I'm sure it works, both with a normal ping and with the multicastTest, and in both ways. So multicast doesn't seem to be the problem. I've also tried your second solution using unicast lus discovery, but I still have the same error. Do you see anything else I could have neglected ?

gtinon gravatar imagegtinon ( 2008-06-25 09:41:48 -0600 )edit
  • Is there a chance your windows machine running some sort of anti virus? Please disable it.
  • Are u sure the windows and linux boxes running the same product build? Use the PlatformVersion command to make sure these have the same build.

Shay

shay hassidim gravatar imageshay hassidim ( 2008-06-25 15:24:19 -0600 )edit

It's working and I effectively missed something simple ! The problem was in fact in the setenv.sh script, caused by some quotes: NIC_ADDR=192.168.0.4; I just replaced them by normal ones (").

Thanks for your help.

Guillaume

gtinon gravatar imagegtinon ( 2008-06-26 04:00:13 -0600 )edit

I will report this to R&D to be fixed.
Sorry for the inconvenience.
Shay

shay hassidim gravatar imageshay hassidim ( 2008-06-26 09:48:27 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2008-06-25 04:17:00 -0600

Seen: 55 times

Last updated: Jun 25 '08