Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

Persistent space initial_load not working

I'm having an issue deploying a persistent space with initial_load set to 0. Basically it looks as if it just ignores it. It works fine when deployed as a standalone space, but when deployed in a non-default topology (replicated in my case), it still preloads the objects.

I'm starting the embedded space with...

pudeploy -cluster schema=sync_replicated total_members=2,1 -properties mySpace embed://space-config.engine.initial_load=0 event-worker

The evenet-worker pu has a pu.xml definition for the persistent space. I also updated the initial_load in the persistent-space-schema.xml and gs.properties, still no go.

{quote}This thread was imported from the previous forum. For your reference, the original is [available here|http://forum.openspaces.org/thread.jspa?threadID=1956]{quote}

asked 2008-03-12 15:22:17 -0500

isterin's avatar

updated 2013-08-08 09:52:00 -0500

jaissefsfex's avatar
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

The initial_load used only when running in LRU cache policy mode.
Shay

answered 2008-03-12 15:51:12 -0500

shay hassidim's avatar
edit flag offensive delete link more

Comments

So is there any other way of making the objects not preload?

Ilya

isterin's avatar isterin  ( 2008-03-12 16:02:03 -0500 )edit

YES. Override the HibernateDataSource.initialLoad().

Shay

shay hassidim's avatar shay hassidim  ( 2008-03-12 16:07:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2008-03-12 15:22:17 -0500

Seen: 121 times

Last updated: Mar 12 '08