Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question

space persistence and fifo.


I am new to GigaSpaces, and have a question about persisting a space and the fifo attribute.

In my pu.xml file.

<os-core:space id="space" url="/./Chaordix" schema="persistent"/> -- works. i.e. the space persists and restores nicely. <os-core:space id="space" url="/./Chaordix" fifo="true"/> -- works

OR, alternatively

<os-core:space id="space" url="/./Chaordix?fifo"/> -- works <os-core:space id="space" url="/./Chaordix?schema=persistent"/> -- works i.e. the space persists and restores nicely.


<os-core:space id="space" url="/./Chaordix" schema="persistent" fifo="true"/> OR <os-core:space id="space" url="/./Chaordix?schema=persistent" fifo="true"/> produces the following error:

java.lang.RuntimeException: org.openspaces.core.InvalidFifoTemplateException: Template was introduced with a non-matching FIFO order. Rejected attempt to set the class com.chaordix.world.Member with FIFO true [note: this ?Member? class is a POJO]

<os-core:space id="space" url="/./Chaordix?schema=persistent&fifo=true?/> simply hangs when attempting to parse the pu.xml file.</p> <p>My question is: Is there a simple, straightforward way to persist a space and have fifo set to ?true?? I am not understanding why the two seem to be mutually exclusive.</p> <p>Thanks!</p> <p>Cameron</p> <p>{quote}This thread was imported from the previous forum. For your reference, the original is [available here|http://forum.openspaces.org/thread.jspa?threadID=2030]{quote}</p> ">

asked 2007-12-11 16:21:00 -0500

cameronf gravatar image

updated 2013-08-08 09:52:00 -0500

jaissefsfex gravatar image
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

An xml attribute cannot contain an & sign as-is. You need to escape it thus:


Your url should read:

<os-core:space id="space" url="/./Chaordix?schema=persistent&fifo=true?/></p> <p>I deployed a space using the gs-ui, using a pu.xml that contained your os-core:space element above.</p> <p>The exception thrown showed that XML thought that " fifo"="" was="" an="" entity="" (since="" you'd="" put="" an="" '&'="" immediately="" in="" front="" of="" it,="" and="" xml="" was="" looking="" for="" the="" closing="" ';'="" -="" which="" is="" how="" xml="" does="" entity="" escaping).<="" p="">



answered 2007-12-12 18:58:03 -0500

toby gravatar image
edit flag offensive delete link more


Ha - and that didn't work! My XML was expanded. Let me try again. The url should read:

<os-core:space id="space" url="/./Chaordix?schema=persistent&fifo=true?/></p> ">

toby gravatar imagetoby ( 2007-12-12 18:59:04 -0500 )edit

There - now you can see the URL the way it should be written in your pu.xml - note the & construct - you need to remember this is XML we're dealing with!

toby gravatar imagetoby ( 2007-12-12 19:00:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2007-12-11 16:21:00 -0500

Seen: 54 times

Last updated: Dec 12 '07