Setting port number for RMIRegistry

I wish to explicitly specify the port numbers that GigaSpaces uses for all of its various components.

I have been following the instructions at http://www.gigaspaces.com/wiki/displa... to change the port defaults. For example, I have specified the following in gs.properties:

{code}com.j_spaces.core.container.directory_services.jndi.url=localhost:9999{code}

However, when I startup my GigaSpaces instance (gsInstance.bat/.sh) I see this message in the console output:

{quote}{color:green}Jan 30, 2007 4:59:49 PM INFO [com.gigaspaces.container]: Created RMIRegistry on: < localhost:10098 >{color}{quote}

It appears the RMI Registry is starting up on its default port. Later in the console trace I see this output, which indicates that some lookups are being attempted that assume the registry listens on port 9999:

{code}WARNING [com.gigaspaces.admin]: Failed to receive MBean Server.java.io.IOExcepti on: Cannot bind to URL [rmi://localhost:9999/jmxrmi]: javax.naming.ServiceUnavai lableException [Root exception is java.rmi.ConnectException: Connection refused to host: localhost; nested exception is:{code}

Do I need to specify elsewhere what the rmiregistry port number should be?

{quote}This thread was imported from the previous forum. For your reference, the original is [available here|http://forum.openspaces.org/thread.jspa?threadID=2178]{quote}

asked 2007-01-30 16:06:02 -0500

brosnt gravatar image

updated 2013-08-08 09:52:00 -0500

jaissefsfex gravatar image
edit retag flag offensive close merge delete