Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

Installation and Configuration FAQ

Q: I'm running GigaSpaces with Tomcat/Weblogic/other application server and it complains about SAX parser. Is there any workaround? A: GigaSpaces uses the latest standard libraries from Apache Xerces and Xalan as part of the product. In order to use the default XSL/XML parsers use the following system property in the java command: {color:darklue}-Dcom.gs.use-default-xml-parser=true{color}

{quote}This thread was imported from the previous forum. For your reference, the original is [available here|http://forum.openspaces.org/thread.jspa?threadID=2323]{quote}

asked 2006-01-09 12:54:05 -0500

eugene berman gravatar image

updated 2013-08-08 09:52:00 -0500

jaissefsfex gravatar image
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

*Q: How do I instruct GigaSpaces server to use the specific JDK installation?
Q: Does GigaSpaces requires any environment variables to be set?*
A: It is recommended to set environment variable *JAVAHOME *prior to starting GigaSpaces server; if the value is not set, GigaSpaces uses the default *JAVAHOME *value, which is defined in {color:darklue}GS_ROOT/bin/setenv.bat(sh){color}.

answered 2006-01-09 12:58:00 -0500

eugene berman gravatar image
edit flag offensive delete link more

Comments

Q: My GigaSpaces server runs behind the firewall. How do I configure it to use only predefined ports? A: 1. In space config xml (or space schema), locate the following:

{color:darklue}*
<protocol-name>RMI</protocol-name> <server-port>0</server-port> <client-port>0</client-port> *{color}

Replace "0" with the desired port numbers ??? e.g. 1234 and 1235. Make sure the protocol is RMI and not NIO.

  1. Edit the container config xml, find the following:

{color:darklue}* <jndi> <enabled>true</enabled> <url>localhost:1098</url> </jndi> *{color}

Port 1098 can be replaces with any free port number.

The find the following XML:

{color:darklue}* <connection>
<tcp-port>0</tcp-port> </connection> *{color}

Replace the 0 with any free port number.

  1. If you use static or semi-dynamic cluster, edit the cluster config xml and make sure that port numbers in cluster member URLs match the port numbers in the container config xml.
eugene berman gravatar imageeugene berman ( 2006-01-09 13:05:05 -0500 )edit

Q: How do I enable Jini Transaction Manager service? A: Edit the {color:darklue}GS_ROOT/config/services/start-gigaspaces.config{color} file and make sure you have the following lines uncommented:

{color:darklue} / Jini Transaction Manager / new NonActivatableServiceDescriptor(mahaloCodebase, policy, mahaloClasspath, "com.sun.jini.mahalo.TransientMahaloImpl", mahaloConfig),{color}

eugene berman gravatar imageeugene berman ( 2006-01-09 13:06:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2006-01-09 12:54:05 -0500

Seen: 91 times

Last updated: Jan 09 '06