Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

Gigaspaces loadbalancer configuration with apache httpd server

As per this link I was configured the gigaspaces with appache httpd server.

Here the apache-lb-agent.bat file is generating conf file under the <apache_home_dir>/conf/gigaspaces and the batch script is running without any error.

But while am trying to access the deployed PU from the load balancer (like : localhost/<appname>) I am getting error message as file not found.

Finally I came to know the “httpd.conf” file is don`t have any references about generated proxy configurations , so I copied those configurations to httpd.conf file after that it was working.

Is it a way to configure the gigaspaces load balancer ?

If no, How can i do this without any manual configurations in httpd.conf?

My Environment Details are: XAP - 9.1 Appache Server - Apache2.2

Thanks in advance !

asked 2014-01-23 07:19:33 -0600

Rajamohan gravatar image

updated 2014-01-23 07:35:13 -0600

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

When running the Apache Load Balancer and the agent on Windows, please make sure you run the Apache Load Balancer Agent from a windows cmd started as an administrator user. Starting it as a normal user will not allow the Apache Load Balancer Agent to reset the Apache Load Balancer successfully.

See: http://docs.gigaspaces.com/xap97/apac... http://www.lytebyte.com/2008/10/22/ho...

Shay

answered 2014-01-23 09:53:06 -0600

shay hassidim gravatar image
edit flag offensive delete link more

Comments

Thanks for answering Shay, I am already running the apache load balancer agent with administrator mode only, but its not working :(

Rajamohan gravatar imageRajamohan ( 2014-01-24 05:43:23 -0600 )edit

Hi Shay, I failed to add this " Include conf/gigaspaces/*.conf " in httpd.conf file. Now its working fine :)

Rajamohan gravatar imageRajamohan ( 2014-02-03 08:53:49 -0600 )edit

Ok. Cool. Thanks. Was this missing from the documentation?

shay hassidim gravatar imageshay hassidim ( 2014-02-03 10:19:39 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-23 07:19:33 -0600

Seen: 25,966 times

Last updated: Jan 23 '14