Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question
0

Disabling multicast for lookupservice discovery only

Hi,

Is it possible to disable lookupservice discovery over multicast but use multicast as communication protocol for notifying space listeners?

According to [ http://www.gigaspaces.com/wiki/displa... ]: +"For unicast discovery only, you should disable multicast using -Dcom.gs.multicast.enabled=false system property"+

But doesn't that disable multicast in the whole system? see Multicast settings on [ http://www.gigaspaces.com/wiki/displa... ].

/Elias

{quote}This thread was imported from the previous forum. For your reference, the original is [available here|http://forum.openspaces.org/thread.jspa?threadID=3757]{quote}

asked 2011-09-29 06:31:28 -0500

eliaslindholm gravatar image

updated 2013-08-08 09:52:00 -0500

jaissefsfex gravatar image
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

Elias,

Multicast based notifications does not use the same mechanism used with the multicast based lookup service discovery. These are separate components within GigaSpaces kernel. You can disable multicast based discovery and use multicast based notifications.

Any special reason why the default unicast based notifications would not work in your case? multicast based notification is rarely used since it is using unreliable based communication, which may drop packets.

Shay

answered 2011-09-29 10:14:45 -0500

shay hassidim gravatar image
edit flag offensive delete link more

Comments

Thanks for the clarification.

We are testing how different configurations are affecting the throughput of messages when having many listeners. In our case we are distributing stock quotes, so some losses are acceptable. We started with unicast based notification and want to compare it with multicast, but we have trouble to get multicast based notifications working. I will start another thread about that.

eliaslindholm gravatar imageeliaslindholm ( 2011-09-30 03:19:45 -0500 )edit

To increase the capacity of the amount of notifications the space can send please increase the space-config.engine.notify_max_threads (space property) to a larger value than the default (128) and increase also the com.gs.transport_protocol.lrmi.max-threads (system property) to a larger value than the default(128). Having a value of 512 for both parameters should provide better behavior.

http://www.gigaspaces.com/wiki/displa...http://www.gigaspaces.com/wiki/displa... Shay

shay hassidim gravatar imageshay hassidim ( 2011-09-30 06:54:56 -0500 )edit

Thanks!

I will test how those parameters will affect the throughput.

Any suggestions how I can solve my trouble with multicast? (see //question/962/multicast-based-notifications/&tstart=0)

/Elias

eliaslindholm gravatar imageeliaslindholm ( 2011-10-03 02:25:22 -0500 )edit
0

Disabling multicast on locator would disable multicast discovery of all services on that locator. Gigaspaces using jini protocol for discovery and service management etc and rest is TCP.

FYI Notify is also a TCP so disabling multicast wouldn't be a problem

http://en.wikipedia.org/wiki/Jini

answered 2011-09-29 10:18:00 -0500

venkatg gravatar image
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-09-29 06:31:28 -0500

Seen: 179 times

Last updated: Sep 29 '11