Welcome to the new Gigaspaces XAP forum. To recover your account, please follow these instructions.

Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Redo logs are overflowing to disk even though they are configured to "drop-oldest"

Hi,

I am testing various redo log configurations with a Mirror that sends data to a database with Gigaspaces 10.1. I noticed that even if I choose 100% of the redo logs should be saved in memory with “drop-oldest” configuration specified, I always see the redo logs overflowing to disk when I disable the network connection to the database. I am not sure why this is the case as I would expect the redo logs to be kept in the spaces?

Example Space configuration: 2048m,20480m,1 i.e. 20GB maximum memory capacity divided into 10 spaces, each space being 2GB. 1 Mirror Service space = 2GB cluster-config.mirror-service.redo-log-capacity = 100000 cluster-config.groups.group.repl-policy.redo-log-memory-capacity = 100

I have tried to decrease the number of packets saved in the redo logs to 20000 and and am seeing the same issue.

Thanks, KP